Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-2264

Lock DSpace 5.x dependency versions for Mirage 2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.0
    • Fix Version/s: 5.0
    • Component/s: None
    • Labels:
    • Attachments:
      0
    • Comments:
      3
    • Documentation Status:
      Not Required

      Description

      The version numbers for several Mirage 2 dependencies are defined as "latest" in the bower.json configuration file.

      https://github.com/DSpace/DSpace/blob/master/dspace-xmlui-mirage2/src/main/webapp/bower.json

      This is great for development, as developers will automatically get the latest versions.

      This is not recommended for a release distribution as it can lead to unforeseen problems, caused by new versions of the dependencies.

      => We propose to lock the versions on master now and on the new Dspace 5x dev branch.
      => Once master will be used for DSpace-6 snapshots, we can turn those back to latest, to ensure new developments are using the most recent versions of the dependencies.

      We need to get the PR in before the RC1 release today.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              helix84 Ivan Masár
              Reporter:
              bram Bram Luyten (Atmire)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: