Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-4348

DSpace 6 should support Java 11

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Volunteer Needed (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 6.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      2
    • Documentation Status:
      Needed

      Description

      DSpace 6 currently depends on Java 8. It does not run with Java 11. Oracle stopped public updates for Java 8 for commercial users in January 2019. It will provide free public updates for personal users at least until December 2020. AdoptOpenJDK is providing support at least until September 2023. Nevertheless, major Linux distributions like Debian 10 Buster, does not contain packages for Java 8 anymore.
      DSpace 6 is the last DSpace version that contains XMLUI and JSPUI. The DSpace community supports the last three major versions of DSpace. DSpace 6 will be supported until DSpace 9 is released or the community changes this rule. In the past we planed to have one major release per year (or less) which makes it very likely that DSpace 6 should be supported by the community after September 2023.
      Should we add support for Java 11 to DSpace 6?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              pbecker Pascal-Nicolas Becker
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated: