Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-4497

Upgrade to Solr v8

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Accepted / Claimed (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 7.0
    • Fix Version/s: 7.0
    • Component/s: Discovery, DSpace API
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      3
    • Documentation Status:
      Needed

      Description

      In DS-3695, we upgrade the DSpace 7 codebase to Solr v7.3.1

      Unfortunately, since that time, Solr v7.3.1 is also considered EOL: https://lucene.apache.org/solr/downloads.html#about-versions-and-support

      At a minimum, we should upgrade to v7.7.x (which is still supported). However, this seems like a good opportunity to simply upgrade to v8 (currently v8.5.1) as that's the current version. Additionally, since we'll already be needing to do a major Solr update in DSpace v7, it seems reasonable to just jump directly to Solr v8.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mwood Mark H. Wood
              Reporter:
              tdonohue Tim Donohue
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated: