Details

    • Type: Story
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Fedora 3.5
    • Fix Version/s: Fedora 3.6
    • Component/s: None
    • Labels:
      None

      Description

      As a developer using Eclipse Indigo (3.7) with m2e (Maven Integration for Eclipse), I would like to be able to create and use an Eclipse project for the Fedora sources.

      Recent versions of m2e (post 0.12) differ significantly in their project lifecycle bindings, generating numerous "Plugin execution not covered by lifecycle configuration" errors as well as failing to identify the generated sources directory in fcrepo-common which is responsible for numerous build errors in the various Fedora modules that depend on fcrepo-common.

      Previously, the only (two) error markers were related to the circular dependency between fcrepo-common and fcrepo-server (where fcrepo-server depends on the generated sources in fcrepo-common, but fcrepo-common's generated sources depend on fcrepo-server classes). Ideally, with respect to Eclipse error markers, Fedora with Eclipse 3.7.x and m2e 1.x should be on par with Fedora with m2e 0.12.

        Attachments

          Activity

            People

            Assignee:
            eddie Edwin Shin
            Reporter:
            eddie Edwin Shin
            Reviewer:
            A. Soroka A. Soroka
            Votes:
            3 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: